18 March, 2012

You do not have permissions to open this file on Excel Services


If you are troubled with the above errors in SharePoint while publishing and viewing the excel services forms in browser then I believe you are in the right place. I am not sure if my guidelines will solve your problem but at least it solved my issues.

Resolution:
1. In SharePoint Central Administration, go to 'Manage this farm's shared services'

2. Select your shared service. (Default is SharedServices1)

3. In 'Excel Services Settings' select Edit Excel Services settings.

4. Ensure that File Access method is Process Account. Click OK.

5. Back in 'Excel Services Settings' select 'Trusted File Locations'

6. Add a new Trusted file Location:
 > URL: Specify the report library or the entire portal

 > Location Type: Windows SharePoint Services

 > Children: Trusted

If you have any queries/questions regarding the above mentioned information then please let me know.
I would be more than happy to help you as well as resolves your issues, thank u

Office documents prompting for credentials

Multiple users are suddenly facing problems while accessing sharepoint site.

SYMPTOMS:
Users are prompted for credentials when accessing Office documents via ISA. 

Customer is using Forms-Based Authentication [FBA] to authenticate external users.

ERROR MESSAGE:
None

ENVIRONMENT:
Office SharePoint Server 2007

CAUSE:
ISA defaults to a settings "Never use persistent cookies"

Resolution:
On the SharePoint site - 

On the properties of the SharePoint publishing rule on ISA, 
go to the following location - Listener - Forms - Advanced Form Options - Cookie Settings - Use 
Persistent Cookies - set this to “On All Computers” (the default setting is “Never use persistent cookies”)

If you have any queries/questions regarding the above mentioned information then please let me know. I would be more than happy to help you as well as resolves your issues, thank you.

Excel 2010 articles, fixes and updates - Year 2011


This list contains all of the known Microsoft Knowledge Base articles, howtos, fixes, hotfixes, webcasts and updates of Microsoft Excel 2010 that have been released in Year 2011


2555016 Excel 2010 may crash when using HP Printers Q2555016 KB2555016 June 13, 2011











2528533 Office 2010 Cumulative Update for April 2011 Q2528533 KB2528533 April 28, 2011



























2493730 Office 2010 Cumulative Update for February 2011 Q2493730 KB2493730 February 28, 2011




2273257 Office Application Custom Code Solutions Q2273257 KB2273257 February 21, 2011



2276904 Office Deployment Q2276904 KB2276904 January 12, 2011

2479673 Office 2010 Cumulative Update for December 2010 Q2479673 KB2479673 January 6, 2011

You are attempting to open a file that is blocked by your registry policy setting.

Number of error messages that will be fixed when you will apply the resolution:

You are attempting to open a file that is blocked by your registry policy setting.

You are attempting to open a file type <<File Type>> that has been blocked by your File Block settings in the Trust Center.

You are attempting to open a file that was created in an earlier version of Microsoft Office. This file type is blocked from opening in this version by your registry policy setting.

You are attempting to save a file that is blocked by your registry policy setting.

You are attempting to save a file type <<File Type>> that has been blocked by your File Block settings in the Trust Center.

Your error message will be anyone which are mentioned above. but don't worry Microsoft has already published a KB for this and your issue will be resolved when you will apply the mentioned resolution.

Resolution:
To resolve this issue, click the following article number under the name of the Office program that you are using to view the article in the Microsoft Knowledge Base: 

Word 2010, Word 2007, or Word 2003
Excel 2010, Excel 2007, or Excel 2003
PowerPoint 2010, PowerPoint 2007, or PowerPoint 2003
I receive an error message when I try to open or save a file in PowerPoint


If you have any queries/questions regarding the above mentioned information then please let me know. I would be more than happy to help you as well as resolves your issues, thank you

The provided Secure Store target application is either incorrectly configured or does not exist


Yesterday, i was configuring Schedule PowerPivot Data Refresh as per this microsoft article: 
What i did exactly ?
-Open a SharePoint 2010 site
-Uploads Powerpivot
-selects schedule a data refresh for the workbook
-at step 7, i have selected third option i.e. The user enters a known existing Secure Store Target application ID in the Credentials section inside the "Connect using the credentials saved in Secure Store Service" field.
-Clicks OK to save the schedule and got the following error message:
"The provided Secure Store target application is either incorrectly configured or does not exist"

I have successfully resolved this issue by following the below mentioned steps:
Note: I am still debugging this issue to find out the root cause. Will share the details asap.

Resolution Steps:
1.       In Central Administration browse to Application Management 
2.       Click Manage Service Applications
3.       Click to the right of the Secure Store Application link so the row appears highlighted. The objective is to activate the Administrators button in the menu ribbon.  
4.       Click on the Administrators button and add the user (or an appropriate security group including user) to the field.  
5.       Click Add, and then check the "Manage target applications" check box.

If you have any queries/questions then please let me know. I would be more than happy to help you as well as resolves your issues, Thank you

17 March, 2012

When opening an excel file I get the following error "This workbook cannot be opened because it is not stored in an Excel Services Application trusted location.

If you are working on Office Web apps in SharePoint 2010 then you may come across this error…
“This workbook cannot be opened because it is not stored in an Excel Services Application trusted location.
To create an Excel Services Application trusted location, contact your system administrator.”

its very simple to resolve this error and start working on excel again :-)
there are 2 methods to resolve this issue:

Option 1: Configure to open in Client Application
At the site collection level activate the "Open Documents in Client Applications by default Feature"

Option2: At the Document Library set the "Opening Documents in the Browser" setting to "Open in client application"

OR
  1. open central admin 
  2. go to Manage service applications
  3. Click on Excel services Application.
  4. Then click on “Trusted file locations”
  5. You can see that http:// is already there, so you could just add https:// or put in a url to a specific location
  6. Fill in the boxes, I also ticked the trust children box.
  7. Once you have done this go back to your Excel document and it will open up in the browser. 
If you have any queries/questions regarding the above mentioned information then please let me know, thank you

System error 5 has occurred. Access is denied.

This issue occurs if you use a connection method that uses Windows shell components or Explorer View. For example, you may experience one or more of the following symptoms:

1-if you try to map a drive to a document library by using the net use command, you are prompted to type your user name and password. After you type your user name and password, you receive the following error message:

System error 5 has occurred.
Access is denied.

2-If you try to view a document library by using Explorer View, you are prompted several times to type your user name and password. If you click Cancel, Explorer View displays Web folders. 
To have us enable Basic authentication on the client computer for you, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.
Fix it for me
To fix this problem automatically, click the Fix it button or link. In the File Download dialog box, click Run, and then follow the steps in the Fix it Wizard.


Fix this problem
Microsoft Fix it 50623

13 March, 2012

How to check-Forms Server is installed on a server or not ?

Problem Description:
Forms Server was installed on a server and you need to verify its installation.


What excatly we need to check for this?
Check whether the Microsoft.Office.InfoPath.Server.dll is installed on the server.

Resolution:To verify the installation of Forms Server you need to check whether the DLL is properly installed on the server and whether the ASP.NET page is present. You can do this as follows:
1.Go to C:\Program Files\Microsoft Office Servers\12.0\Bin\ and check whether Microsoft.Office.InfoPath.Server.dll is present in this folder.
2.Go to C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\LAYOUTS\ and check whether FormServer.aspx is present in this folder.
3.Open the .NET Framework 2.0 Configuration tool by going to Start > Settings > Control Panel, opening the Administrative Tools and then the Microsoft .NET Framework 2.0 Configuration.
4.Click on Manage the Assembly Cache listed under Tasks in the right panel of the .NET Framework 2.0 Configuration dialog box.
5.Click on View List of Assemblies in the Assembly Cache under Tasks in the right panel of the .NET Framework 2.0 Configuration dialog box.
6.Look whether Microsoft.Office.InfoPath.Server is listed among the DLLs that are registered in the Global Assembly Cache (GAC).


Please let me know in case of any queries/questions. I would be more than happy to help you as well as resolves your issues, Thank you

 

11 March, 2012

Security token service is not available

After installing SharePoint Foundation 2010 I noticed a warning in the Central Admin > Review problems and solutions report that the Security Token Service is not available.

The Security Token Service is not available.
The Security Token Service is not issuing tokens. The service could be malfunctioning or in a bad state.
SP Security Token Service (Security Token Service)

This issue happends becuase of the following symptons:

-The following error appears in the SharePoint server’s event log every hour:
“An error occurred while receiving the HTTP response to http://localhost:32843/SecurityTokenServiceApplication/securitytoken.svc. This could be due to the service endpoint binding not using the HTTP protocol. This could also be due to an HTTP request context being aborted by the server (possibly due to the service shutting down). See server logs for more details.”
-Users are unable to log in to SharePoint sites protected by claims authentication.

Probable causes:
1.A required WCF hotfix has not been installed on the SharePoint server
2.Authentication for the SecureTokenServiceApplication is not configured properly in IIS.
3.The web.config file of the SecureTokenServiceApplication contains invalid data
4.The SecureTokenServiceApplication is not provisioned properly.

Resolution:
We have followed the microsoft suggested guidelines and the issue has been resolved:
1.Missing WCF Hotfix: If the server is running Windows Server 2008 SP2, please ensure that the hotfix mentioned at http://support.microsoft.com/kb/971831 is installed. If the server is running Windows Server 2008 R2, the hotfix mentioned at http://support.microsoft.com/kb/976462 must be installed.

2.Incorrect Authentication Settings: Please ensure that the authentication settings for the SecureTokenServiceApplication are correctly configured by completing the following steps:
a) Open IIS Manager
b) Expand “Sites”
c) Expand “SharePoint Web Services”
d) Select “SecurityTokenServiceApplication”
e) From the “Features” pane, double click on “Authentication” under “IIS”
f) Right click “Forms Authentication” and select “Disable”
g) The authentication settings page should only have Windows and Anonymous access enable for the security token service to issue tokens properly (and for claims authentication to work properly)

3.Incorrect data in the configuration file: Please review the web.config file of the secure token service application and compare it to a web.config file from a "working" secure token service application.

4.SecureTokenServiceApplication not provisioned: Use the following power shell commands to provision the secure token service application
$sts = Get-SPServiceApplication | ?{$_ -match "Security"}
$sts.Status
$sts.Provision()

If you have any queries/questions regarding the above mentioned information then please let me know. I would be more than happy to help you as well as resolves your issues, Thank you.

10 March, 2012

RCC Call automatically put on hold.

RCC (Click to call) Call automatically put on hold.

Problem Description:-

While using MOC client 2007 R2 and users often complain that when they answer a call on the phone it automatically gets put on hold and it doesn't matter they to answer using speakerphone, headset or headset. If they kill MOC client on their computer and restart it the problem goes away.

Resolution:-
I have reproduced problem on few computers for testing and researched on issue.

-> Only one call is active the other calls are put on hold automatically by communicator, because by design OCS 2007 can only have one active call at a time, it puts other calls on hold.

The call was established on MOC 2007 R2.

When there was a new call coming, MOC found there was two call active so it sent HoldCall event and call put on hold.

Resolution at this point found -

1. Only solutions to quit MOC 2007 R2 or remove RCC from users account.

2. Upgrade the Avaya or Cisco software (soft phone).

08 March, 2012

How Communicator Client Communicate with Address Book Server?

While working as OCS administrator, we must know the communicator client and Address server communication.

Here are the useful information regarding Address Book Server.

The Address Book URLs (that is, one internal and one external) are the paths that clients use to access the data files in the Address Book Server file store. These URLs are configured under the Address Book tab in the Web Components Properties for the given Standard Edition server or Enterprise pool, and are retrieved through in-band provisioning (absInternalServerUrl and absExternalServerUrl) by the client when it logs on to its Standard Edition server or Enterprise pool. The clients can also have these URLs configured through Group Policy Objects.

Communicator client- > Address book Services

Active Directory -> User Replicator -> Database -> Address Book Services -> File Store (NTFS) – IIS 6.0 Server.

04 March, 2012

Script for Listing all Telephone Settings for Remote Click Call user account


Hello Friends,


Many times we need to list the telephone number of users who are enabled for Remote call Control user control.


Here are script which is useful for list the telephone settings.


'List All Telephone Settings for a User Account'


Set objUser = GetObject _
    ("LDAP://cn=Abc,ou=HR,dc=NA,dc=ocs,dc=com")


WScript.Echo "Home Phone: " & objUser.homePhone
WScript.Echo "Pager: " & objUser.pager
WScript.Echo "Mobile phone: " & objUser.mobile
WScript.Echo " IP Phone: " & objUser.ipPhone
WScript.Echo "Information: " & objUser.info
WScript.Echo " Fax Number: " & objUser.facsimileTelephoneNumber


WScript.Echo "Other Home Phone:"
For Each strValue in objUser.otherHomePhone
    WScript.Echo strValue
Next


WScript.Echo "Other Pager:"
For Each strValue in objUser.otherPager
    WScript.Echo strValue
Next


WScript.Echo "oOther Mobile Phone:"
For Each strValue in objUser.otherMobile
    WScript.Echo strValue
Next


WScript.Echo "Other IP Phone:"
For Each strValue in objUser.otherIpPhone
    WScript.Echo strValue
Next


WScript.Echo "Other Fax Number:"
For Each strValue in objUser.otherFacsimileTelephoneNumber
    WScript.Echo strValue
Next




Thank you!