Showing posts with label SharePoint 2007. Show all posts
Showing posts with label SharePoint 2007. Show all posts

02 June, 2014

Maximum upload size in SharePoint 2013

As the SharePoint can be use one of best repository tool in today’s market, we uploads so many files to SharePoint document library on regular basis and face some generic error message also “you have cross the upload limit which has been configured by web administrator” & so many others!

Today’s article is based on this “maximum upload” information and what’s under the hood? Where is this setting coming from?

Here is the information that you are looking for!
The maximum file upload size is a web application setting that specifies the maximum size of a file that a user can upload to the server. You configure the maximum file upload size for every web application by using Central Administration to specify the size of files that will be uploaded to asset libraries.

By default, the maximum video file upload size is 250 MB. You can increase the video file upload size to 2 GB.

How to change this in CA?
1.    Central Administration
2.    Application management
3.    Manage web applications
4.    Select the correct web application in which you wanna do the changes
5.    General settings (from the ribbon)
6.    You will see the section named as “Maximum upload size”
7.    Change the value as per the requirement and click OK.
8.    That’s it & you are done!

If you have any queries/questions regarding the above mentioned information then please let me know. I would be more than happy to help you as well as resolves your issues, Thank you.

20 October, 2013

Event ID 5586

Issue: Event ID: 5586 Generated in the SharePoint server.

Error: Event ID 5586 generated in SharePoint server application event logs.

Event Type:      Error
Event Source:  Windows SharePoint Services 3
Event Category:            Database
Event ID:          5586
Date:                09/10/2013
Time:               10:24:22
User:                N/A
Computer:        ++++++++++++
Unknown SQL Exception 1035 occurred. Additional error information from SQL Server is included below.

As a part of daily health check on the server, I have noticed allot many occurrences of the event ID 5586 on multiple servers.

This is something occurs on regular intervals but not specific to one server.

By looking some of the reference on the internet I happened to find the TechNet Article which talk about the possible resolution of this error.

This error occurs in both the versions of the SharePoint i.e. 2007 and 2010; however in my case it was reported for the SharePoint 2007.

Great thanks to MS to keep the record of the most relevant event IDs and sharing the possible remedies

If you feel any difficulty in following any of resolution listed in the articles, do let me know. I would be more happy to help you put with.

Products Applies to:
1)      SharePoint 2007
2)      SharePoint Server 2010
3)      Windows Sever 2003
4)      Windows Server 2008
5)      SQL Server 2005 and SQL Server 2008.

18 September, 2013

You do not have the necessary permissions to use the '' object" + SharePoint2007 + Access

Issue: Connecting a List to Access database throws an error message.

You do not have the necessary permissions to use the '' object. Have your system administrator or the person who created this object establishes the appropriate permissions for you.

Background: One of my clients trying to connect a SharePoint List by MS Access. After waiting some time, getting error message specified above. Also getting the same error message when trying to connect to MS Access from SharePoint by converting the list to data sheet view

System Information:
1)   Windows XP
2)   Office 2007
3)   Access 2007
4)   Access 2010
5)   SharePoint 2007

1)   Tried to save list as a template and created a new list issue persist in both cases when saved with content and without content.
2)   Tried to connect same list to excel and did not work.
3)   Tried repairing the office suit, didn’t work at all.
4)   This seems to be clearly an issue with the SharePoint List.

Tried looking at columns side of the list and did some deep dive based of the exact error were getting and found the below KB from MS, which was the resolution of the problem and gave a clear instructions to reproduce the issue.

Checked the columns names on the List and there were two columns which were using more than 64 characters in it title field.

Eliminating them from the list and connecting List again from MS Access to SharePoint does work and vice versa.

Applies to:
1)   Windows SharePoint Service 3.0
2)   MOSS 2007, MS Access 2007
3)   MS Access 2010.

If you have any queries/questions regarding the above mentioned information then please let me know.I would be more than happy to help you as well as resolves your issues, thank you.

29 April, 2013

Cannot browse to All People in SharePoint 2010

We used to normally visit All people in Sharepoint 2007 to Delete the user from the Site collection :)

Where is it in Sharepoint 2010 ?

The “All People” view is the best way to list out all the users having access to the SharePoint site.

When a admin navigates to the “People and Groups” section in a SharePoint 2007 site,

he sees a link called “All People” in the left hand navigation.

Clicking on this link brings up a view of all the users across all the groups in the site.

But this “All People” view is hidden in SharePoint 2010 and the link is also missing in the “People and Groups” section.

However one can still navigate to this view in a SharePoint 2010 by following the below mentioned steps :
  • Navigate to the “People and Groups” section.
  • Click on any of the groups.
  • Locate the “MembershipGroupId” query string parameter from Url in the address bar
  • Replace the value in the “MembershipGroupId” query string parameter with 0.
  • Reload the page and it will populate the “All People” View.

21 February, 2013

Code Blocks are not allowed in this file error in sharepoint 2010

Hello Everybody,
Today I worked on one critical issue which belongs to our development environment. We have migrated one web application from production environment to development for testing purpose. Migration has been successful but we were facing an exception while browsing the web application.

Error Message:
An error occurred during the processing.
Code blocks are not allowed
Troubleshoot issues with Microsoft SharePoint Foundation.

Server Configuration:
·         2 SharePoint Servers
·         SQL server 2008 R 2
·         Windows Server 2008 R2
·         SharePoint Version: SP2010

Troubleshooting done:
1.    Tried accessing the system pages i.e. settings.aspx, viewlsts.aspx etc. every system was opening fine without any issues. So the issue is with the home page only…
2.    Tried accessing the web part maintenance page, it opened without any issues. We closed the webparts which are present on the home page-just to make sure that there is no problem with the existing webparts. Checked the home page again but same issue.
3.    Tried changing the master page as were able to open the system pages (by appending _layouts/changesitemasterpage.aspx). We changed to different one as we are using custom master page. Checked the results again but same problem.
4.    Opened the site in SharePoint Designer 2010 and checked the status of master page as well as the home page. It was fine and without customization too.

Note: if you see any of these pages in customizable state then I would suggest you to take the backup and try ‘reset to site definition” option.

Obviously, next question will arise- what exactly it will do? Yes, it will reset your page to default state. It means you will lose your customizations. But issue will be resolved and you can customize the page again as per your requirements.

5.    Checked the windows application as well as SP logs (Location: \14\Logs). I would suggest you to analyze these logs before continuing your troubleshooting.

What is my observation\Understanding?
·         Code blocks are only processed for custom pages deployed in the root virtual directory of a site if the code it considered safe.
·         This code is considered safe only if the page is served directly from the file system. As soon as it becomes unghosted for any reason, the code is no longer considered safe and the error shown in the symptom occurs.

As our production web application was working without any issues so I compared the web.config of both the applications. Analyze the code line by line with the production web.config and that’s it. I found the one which was missing in the web.config that belongs to my development web application.

Note: I would suggest you to take a proper backup before making any changes in the web.config file.

What I did? What kind of entries I added in the web.config file?

Here we go:-
In you web.config, you need to search the tag name as “<PageParserPaths>”
Once you find that then make the following  entry:
    <PageParserPath VirtualPath="/apps/*" CompilationMode="Always"
              AllowServerSideScript="true" IncludeSubFolders="true" />
After adding this entry then IISRESET is mandatory.

Tried accessing the site and the issue has been resolved.

Happy SharePoint once again…

If you have any queries/questions regarding the above mentioned information then please let me know, Thank you.

23 December, 2012

"List from Spreadsheet" using SharePoint Designer 2010 throws "An unexpected error has occurred"

We are all aware about ‘How to import a spreadsheet’ from normal GUI functionality. This time I was playing the same functionality with SharePoint Designer 2010 and faced some challenges. I would like to share the exact steps as how we can reproduce the same error and workaround for the same.

Problem Description: If you try to import a spreadsheet from within SharePoint Designer 2010 to create a list in SharePoint 2010 you get an error

"An unexpected error has occurred."

Steps To Reproduce:
1.     Browse to a SharePoint site 
2.     From the Site Settings menu click on "Edit In SharePoint Designer" 
3.     Within SharePoint Designer, choose left menu "Lists and Items" 
4.     From the Ribbon menu click "List from Spreadsheet" 
5.     SharePoint Designer will launch the SharePoint site within a browser 
6.     Add a title on the list and choose File then click Import 
7.     You will get error message "An unexpected error has occurred" 

The URL when you try to load the page from SharePoint Designer will look something like the following and it will not work:

Append to the URL on the page that is being called from SharePoint Designer with the following and reload the page.



If you have any queries/questions regarding the above mentioned information then please let me know. I would be more than happy to help you as well as resolves your issues J J

07 December, 2012

Webpart Chrome type is not working or Webpart Title is not working: SharePoint

Webpart Chrome type is not working or  Webpart Title is not working: SharePoint
Today one of my user complained that she was not able to set the title of her web parts on various pages on her site.  When setting the chrome type to ‘Title’ it set it back to none, when we hit apply and Ok o the web part page. Hence leading to a problem of Webpart Chrome type is not working as expected.
- We tried setting chrome type to other types. No luck.
- We tried changing the various properties of the Webpart, but no luck.
- While researching on the internet I came across an article which says that forcibly changing the
we implemented the same on the effected page and it doesn’t correct the problem.
- One of the article talks about the problem with the webpart zone, when comparing the webpart zone of the webpart with other webpart on the other sites, it was showing only one webpart zone= main.
This article talks about the resolution but doesn’t show how to do it.
To do this, Open the site in SPD, go to faulty page, and open the page in the coding mode. Look for the webpart page main property.

Change the ID of the webpart to anything other than “Main”. It would bring back the tittles on the webpart. I am not sure why this issue problem had occurred but now it has corrected the problem.

Another Post which talks about the same issue:
If you have questions/queries, do let me know. I would be more happy to help you.

18 November, 2012

Sales Lead Pipeline Template Mystery

Before directly giving the problem description, let me brief some details regarding Sales Lead Pipeline template. This template belongs Microsoft Fab40 Package and comes under “Server Admin Application Templates”, detail reference:

Problem Description:
User created a Website with the Template "Sales Lead Pipeline". It works well, but there is a Workflow inside this Template to convert leads to accounts. This workflow only work with the side admin account (i.e. only for site collection administrators), all other accounts became an "access denied".

We can enter sales leads into the site but when we push the convert button, or use the convert workflow "Access Denied" is returned. User is a member of both the associated members and owners groups. So now the questions is-Do we really required to be a part of site collection admin group?

Which states that this is a bug in this template and there are some steps by which we can fix this.

Resolution Steps:
1)    Open your sales site with SharePoint Designer
2)    Go to the workflows
3)    Click on the "Convert" workflow with the right button
4)    Click on "Publish selected file"
5)    Choose any location
6)    Click publish

If you have any queries/questions regarding the above mentioned information then please let me know. Thank you.