22 April, 2009

Cannot open file: it does not appear to be a valid archive. If you downloaded this file, try downloading the file again.

After you download a .ZIP file from a Microsoft Windows SharePoint Services document library, and then you try to open the .ZIP file, you may receive the following error message:
Cannot open file: it does not appear to be a valid archive. If you downloaded this file, try downloading the file again.

CAUSE
This problem may occur if HTTP compression is turned on in the Web Sites properties of Microsoft Internet Information Services (IIS) on the SharePoint virtual server. When you download a .ZIP file, IIS encodes the file as GZIP. However, the browser client passes the file directly to the unZIP program, without GZIP decoding the file. To determine if HTTP compression is turned on, follow these steps:
1. Click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
2. Expand the server (local computer) tree, where server (local computer) is the name of your IIS server.
3. Right-click Web Sites, and then click Properties.
4. Click the Service tab to view the HTTP compression properties.

Resolution:

change the MIME type for the .ZIP file from application/x-zip-compressed to application/octet-stream . To change the MIME type, follow these steps:

1. Click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
2. Right-click the server (local computer) tree, where server (local computer) is the name of your IIS server, and then click Properties.
3. Click MIME Types.
4. Scroll down the registered MIME type list to find the .zip entry.
5. Click the .zip application/x-zip-compressed entry, and then click Edit.
6. Change the MIME type value to application/octet-stream .
7. Stop and then restart the IIS Admin Service to apply the change to the MIME type.

The file that you selected could not be found

Few Days before, in our project, one of the user faced wierd error message which was never seen by my team. First of all lets focused the whole error message:
"The file that you selected could not be found. Check the spelling of the file name and verify that the location is correct."

When trying to open the sample dashboard in MOSS 2007 Enterprise Report Center site as an user with Read Only rights, we got this error message.
While troubleshooting, we compared two document libraries and reproduced the scenario.
After the excat replication of error message on a new document library,we found out the resolution which is quite simple.

Resolution:-
1. Go to your reports library where the workbooks are stored.
2. On the Settings menu, click Document Library Settings.
3. Under General Settings, click versioning settings.
4. Disable versioning.

I hope the above steps helps you to resolve your issue.
Thanks...