16 August, 2012

SharePoint Foundation 2013 known issues

Recommended configuration for crawling large hosts

When defining content sources to crawl in SharePoint Search, the maximum number of threads that can simultaneously make requests to a host is set to 12 by default OOB. This value affects the rate of content discovery from the host. For all small and medium sized hosts (<10M), this thread count is sufficient. But if the target host is >10M, we recommend you increase the thread count.

Workaround For large hosts (>10M items), we recommend you set the number of threads to 32 or more. This is over-and-above the recommendation to have dedicated crawl targets that helps manage load on front ends efficiently without impacting performance observed by users of that host.

Some "15" or "2010" strings not updated to “2013” in SharePoint 2013 Preview Management Pack

Some "15" or "2010" strings aren’t updated to "2013" or "2013 Preview" in the User Guide, file names, and some user interface strings of SharePoint 2013 Preview Management Pack.

Workaround No workaround is available.

Management Shell shows an error when open
When you open the Management Shell, you see the following error message:

Could not create a CmdletConfiguration for CmdletName Start-BulkOperation, CmldetClass, CmdletHelpFile C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\CONFIG\PowerShell\Help\Microsoft.Office.Education.Institution.dll-Help.xml.

Cannot process argument because the value of argument"implementingType" is null. Change the value of argument "implementingType" to a non-null value.

Workaround This error doesn't block any scenarios. The shell works for all cmdlets.

PerformancePoint items missing from BI Center left navigation pane

If you create a new BI site collection, you'll see it with navigation links missing.

Workaround To see the links, go to Site Settings > Navigation and change the site to use structural navigation.

Reference Click here

15 August, 2012

Cannot restore from recycle bin

The Recycle Bin provides a safety net when deleting documents, list items, lists, folders and files. When you or site visitors delete any of these items from a Web site, the items are placed in the Recycle Bin.

Problem Description:
Unable to restore files/folders from Site Collection Recycle Bin
When we try to restore we get the following exception:

Error Message: Unable to restore ‘file name’

Troubleshooting Steps:
1)   Checked on the path from where the Folder was deleted and confirmed that it was not modified or deleted i.e. all the top-level folders/sites where intact to get to the folder.

2)   Checked for the available quota on site by means of storman.aspx
·         Open the site
·         Site actions
·         Site settings
·         Site collection administration
·         Storage allocation (storman.aspx)

All looked fine still unable to restore

Resolution:
·         Checked the Document Library where the folder had to be restored and found a folder named similar to the folder which was to be restored. E.g. RC PHASETEST4 as to RC PHASETEST3

·         So, renamed the similar folder to something else and tried restore, it worked. Once restored reverted the renamed folder to original.

If you have any queries/questions regarding the above mentioned information then please let me know. I would be more than happy to help you as well as resolves your issues, Thank you

The folder may be located in an unavailable location, protected with a password, or the filename contain illegal characters

Different users…different issues but all are using the same product i.e. SharePoint
And we are here to resolves the issues and guide them in right directions.

This time-I am sharing in interesting issues which is based on sharepoint designer. User opened a ticket by mentioning that she is getting the following error message while opening the site in sharepoint designer.

The folder 'http://localhost' isn't accessible. The folder may be located in an unavailable location, protected with a password, or the filename contains a / or \.
What needs to be done if we encounter such issues? If we notice carefully then we will come to know that the error message is self explanatory. Ok-what exactly?
Here are the guidelines by which you can check the parameters one by one and get back to me in case of any questions/queries/information required:
1)   There is no such site or folder?
2)   This location is inaccessible because you are using FORM Authentication? You need to extend the web application on another port to connect to SPD.
3)   URL contains illegal characters?
4)   URL contains file names i.e. default.aspx
5)   Check in Central Administration > Application Management > Authentication Providers. Make sure "Enable Client Integration" is set to "Yes".
Thank you. Please feel free to contact/any queries/any questions, I would be more than happy to help you as well as resolves your issues.

Use Central Administration to restore a Web application in SharePoint 2010

To restore a Web application by using Central Administration

1. Verify that the user account performing this procedure is a member of the Farm Administrators group. Additionally, verify that the Windows SharePoint Services Timer V4 service and the Farm Database Access account have Full Control permissions on the backup folder.

2. In Central Administration, on the Home page, in the Backup and Restore section, click Restore from a backup.

3. On the Restore from Backup — Step 1 of 3: Select Backup to Restore page, from the list of backups, select the backup job that contains the farm or Web application backup, and then click Next.

4. On the Restore from Backup — Step 2 of 3: Select Component to Restore page, select the check box that is next to the Web application, and then click Next.

5. On the Restore from Backup — Step 3 of 3: Select Restore Options page, in the Restore Component section, make sure that Farm\ appears in the Restore the following content list.

In the Restore Only Configuration Settings section, make sure that the Restore content and configuration settings option is selected.

In the Restore Options section, under Type of Restore, select the Same configuration option. A dialog box appears that asks you to confirm the operation. Click OK.

Click Start Restore.

6. You can view the general status of all recovery jobs at the top of the Backup and Restore Job Status page in the Readiness section. You can view the status for the current recovery job in the lower part of the page in the Restore section. The status page updates every 30 seconds automatically. You can manually update the status details by clicking Refresh. Backup and recovery are Timer service jobs. Therefore, it may take several seconds for the recovery to start.

If you receive any errors, you can review them in the Failure Message column of the Backup and Restore Job Status page. You can also find more details in the Sprestore.log file at the UNC path that you specified.

14 August, 2012

Error message when you try to add an existing Windows SharePoint Services 3.0 list to an Access 2007 database: "You do not have the necessary permissi

Symptoms:
You try to add an existing Microsoft Windows SharePoint Services 3.0 list to a Microsoft Office Access 2007 database. When the Windows SharePoint Services list contains a column name that has more than 64 characters, you receive an error message that resembles the following:

You do not have the necessary permissions to use the '' object. Have your system administrator or the person who created this object establish the appropriate permissions for you.Note The term "column name" is what you see in the SharePoint user interface. Colum name is the column’s display name.


Cause:
This problem occurs because the Access 2007 database engine disallows columns that have names that contain more than 64 characters.

MS KB Article: