19 March, 2012

Sharepoint custom permission levels

The decision to customize permission levels is less straightforward than the decision to customize SharePoint groups. If you customize the permissions assigned to a particular permission level, you must keep track of that change, verify that it works for all groups and sites affected by that change, and ensure that the change does not negatively affect your security or your server capacity or performance.

Note
You should not customize the default permission levels if your organization has security or other concerns about a particular permission and wants to make that permission unavailable for all users assigned to the permission level or levels that include that permission. In this case, you should turn off this permission for all Web applications in your server farm, rather than change all of the permission levels. To manage permissions for a Web application, in Central Administration, on the Application Management page, in the Application Security section, click User permissions for Web application.

If you need to make several changes to a particular permission level, it is better to create a custom permission level that includes all of the permissions you need.
You might want to create additional permission levels if any of the following applies:
1.       You want to exclude several permissions from a particular permission level.
2.      You want to define a unique set of permissions for a new permission level.
To create a permission level, you can copy an existing permission level and then make changes, or you can create a permission level and then select the permissions that you want to include.

Customize an existing permission level
If the custom permission level that you want is nearly identical to an existing default permission level and you don't need to use the default permission level, you can customize the default permission level to include or exclude permissions that you do or do not need.
1. On the Site Settings page, under Users and Permissions, click Advanced permissions.
2. On the toolbar, click Settings, and then click Permission Levels.
3. In the list of permission levels, click the name of the permission level you want to customize.
4. On the Add a Permission Level page, in the Name box, type a name for the new permission level.
5. Click Submit.

Copy an existing permission level
If the custom permission level that you want is similar to an existing default permission level, and you need to use both the default permission level and your custom permission level, you can copy the default permission level, and then modify the copy and save it as a new permission level.
1. On the Site Settings page, under Users and Permissions, click Advanced permissions.
2. On the toolbar, click Settings, and then click Permission Levels.
3. In the list of permission levels, click the name of the permission level you want to copy.
4. At the bottom of the page, click Copy Permission Level.
5. On the Copy Permission Level page, in the Name box, type a name for the new permission level.
6. In the Description box, type a description for the new permission level.
7. In the list of permissions, select or clear the check boxes to add permissions to or remove permissions from the permission level.
8. Click Create.

Create a permission level
If there is no permission level similar to the one you need, you can create one and include just the permissions that you need.
1. On the Site Settings page, under Users and Permissions, click Advanced permissions.
2. On the toolbar, click Settings, and then click Permission Levels.
3. On the toolbar, click Add a Permission Level.
4. On the Add a Permission Level page, in the Name box, type a name for the new permission level.
5. In the Description box, type a description for the new permission level.
6. In the list of permissions, select the check boxes to add permissions to the permission level.
7. Click Create.

If you have any queries/questions regarding the above mentioned information then please let me know.
I would be more than happy to help you as well as resolves your issues, thank u

What is Central Management Store (CMS) on Microsoft Lync Server 2010?

What is Central Management Store (CMS) on Microsoft Lync Server 2010?

Central Management Store (CMS), which holds information about all the roles and settings in the deployment and it, is newly introduced in Lync Server 2010

CMS replaces the various data stores that were used in OCS. The benefit of this Central Management
Store is that once the topology is defined and published, every installation simply pulls from the defined configuration.

Advantages of CMS:-
Server management centralized, No need to connect server remotely.
 CMS replaced OCS Console. This minimizes administrator input and allows automated deployment.

Certificates are requested and deployed and the fact that the Edge server role can now be centrally managed.
The administrator no longer has to connect remotely to that server to manage it locally.

Available flavour of Lync Server 2010
1.       Lync  2010 Standard Edition (Runs on single server)
2.      Lync 2010 Enterprise Edition.

Like many Microsoft server applications, Lync has a Standard and an Enterprise Edition.

The Standard Edition is fully functional but runs on a single server, using a SQL Express back-end database. It is still supported by other roles, such as the Edge, Monitoring, and Archiving roles, which would still run on other physical server hardware. The supporting roles don’t have a definition of Standard or Enterprise; they simply support the deployed front-end servers. The Enterprise Edition allows for higher availability and more scalability of the roles to support organizations with hundreds of thousands of users. Both versions of the software can be installed only on a Windows Server 2008 or 2008 R2 64-bit operating system (OS) and must be installed on the full GUI version of those operating systems rather than the Server Core version.

How Lync Server 2010 Central Management Store (CMS) look like?

Unable to Load Workbook + The workbook that you selected cannot be opened + The workbook may be in an unsupported file format, or it may be corrupt

Excel services work with Excel 2007 and allows you to share, load, calculate Excel workbooks on Microsoft SharePoint Server 2007 portals and dashboards. You can share an entire Workbook or just few parts of it like charts, tables etc. By using a Web browser, end users can view and interact with the workbooks.

However, at times, when you publish a workbook to Excel Services and try to load it in a browser, you might run into an error message

Unable to Load Workbook
The workbook that you selected cannot be opened.
The workbook may be in an unsupported file format, or it may be corrupt.
Would you like to try and open this file in Excel?

How I resolved this issue:
1)   Remove the space character that is in front of the caret operator in the formula.
2)   Save the workbook in the non-XML binary workbook format (.xlsb). Then, publish the workbook to the server

If you have any queries/questions regarding the above mentioned information then please let me know. I would be more than happy to help you as well as resolves your issues, thank u.

For more information about Excel Services, visit the following Microsoft Web sites:

18 March, 2012

You do not have permissions to open this file on Excel Services


If you are troubled with the above errors in SharePoint while publishing and viewing the excel services forms in browser then I believe you are in the right place. I am not sure if my guidelines will solve your problem but at least it solved my issues.

Resolution:
1. In SharePoint Central Administration, go to 'Manage this farm's shared services'

2. Select your shared service. (Default is SharedServices1)

3. In 'Excel Services Settings' select Edit Excel Services settings.

4. Ensure that File Access method is Process Account. Click OK.

5. Back in 'Excel Services Settings' select 'Trusted File Locations'

6. Add a new Trusted file Location:
 > URL: Specify the report library or the entire portal

 > Location Type: Windows SharePoint Services

 > Children: Trusted

If you have any queries/questions regarding the above mentioned information then please let me know.
I would be more than happy to help you as well as resolves your issues, thank u

Office documents prompting for credentials

Multiple users are suddenly facing problems while accessing sharepoint site.

SYMPTOMS:
Users are prompted for credentials when accessing Office documents via ISA. 

Customer is using Forms-Based Authentication [FBA] to authenticate external users.

ERROR MESSAGE:
None

ENVIRONMENT:
Office SharePoint Server 2007

CAUSE:
ISA defaults to a settings "Never use persistent cookies"

Resolution:
On the SharePoint site - 

On the properties of the SharePoint publishing rule on ISA, 
go to the following location - Listener - Forms - Advanced Form Options - Cookie Settings - Use 
Persistent Cookies - set this to “On All Computers” (the default setting is “Never use persistent cookies”)

If you have any queries/questions regarding the above mentioned information then please let me know. I would be more than happy to help you as well as resolves your issues, thank you.