Problem Description:
Unable
to set alert on a List for single or multiple users
Error Message:
The following users do not have email address specified:
<Username>
Probable cause:
The user’s
profiles are not updated in SharePoint even though everything is setup up correctly
in Active Directory and in Exchange.
Troubleshooting done:
1. Checked if the user is stamped with
an email address automatically.
2. If the user's email address is set
manually, need to remove the exchange attributes and reconnect the mailbox
after running the cleanup agent in exchange, or create a new mailbox if there
was no mailbox for the user in exchange server.
3. Email address is stamped
automatically by recipient update service (RUS) a component of exchange server
and hence one should not add the email address manually.
4. When configuring alert, check if the
users email address is listed in the people picker. In this case the email
address was not displayed; however the email address was stamped automatically
by exchange. ( The affected user's email address was not
5. displayed, but the user who was receiving
alerts success had email address displayed in the people picker)
6. Tried sending a test email from
telnet to the affected user and it got delivered successfully which meant that
the exchange was working fine.
Resolution:
1. Went to Central Admin -> SSP
-> User profiles and properties -> Configure profile import: The default
access account was not specified.
2. Hence gave the enterprise
administrator and the password as the default access account.
3. Then Selected Start Full import under
SSP -> User profiles and properties.
4. We were then able to see all the
users with their email address in View user profiles.
5. Then went to the SSP->Search
Settings -> Content sources and Crawl schedules.
6. Performed a Full crawl which
completed successfully.
7. We then selected the people picker
and found that the all the users were displayed with their email address along
with the affected user.
8. We were then able to set the alert
for that user successfully without getting any errors.
If you
have any queries/questions regarding above mentioned information then please
let me know, Thank you.
Applies to: SharePoint Server 2007-SP2
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Your feedback is always appreciated. I will try to reply to your queries as soon as possible- Amol Ghuge
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