18 November, 2012

Sales Lead Pipeline Template Mystery

Before directly giving the problem description, let me brief some details regarding Sales Lead Pipeline template. This template belongs Microsoft Fab40 Package and comes under “Server Admin Application Templates”, detail reference: http://blogs.technet.com/b/praveenh/archive/2010/12/17/fantastic-40-application-templates-for-sharepoint-wss-amp-moss.aspx

Problem Description:
User created a Website with the Template "Sales Lead Pipeline". It works well, but there is a Workflow inside this Template to convert leads to accounts. This workflow only work with the side admin account (i.e. only for site collection administrators), all other accounts became an "access denied".

We can enter sales leads into the site but when we push the convert button, or use the convert workflow "Access Denied" is returned. User is a member of both the associated members and owners groups. So now the questions is-Do we really required to be a part of site collection admin group?

Which states that this is a bug in this template and there are some steps by which we can fix this.

Resolution Steps:
1)    Open your sales site with SharePoint Designer
2)    Go to the workflows
3)    Click on the "Convert" workflow with the right button
4)    Click on "Publish selected file"
5)    Choose any location
6)    Click publish

If you have any queries/questions regarding the above mentioned information then please let me know. Thank you.

Error message when view or edit in browser for Word or PowerPoint Web Apps

Problem Description:
When attempting to view a PowerPoint Presentation or a Word document in the Office Web Apps, the user receives an error message indicating that the service is temporarily unavailable.  Multiple attempts from the same web application return similar results.

Possible Errors:
1.    Service is temporarily unavailable.
2.    Word Web App cannot open this document for viewing because of an unexpected error.  To view this document open it in Microsoft Word.
3.    PowerPoint Web App encountered an error.  Please Try again.

Probable cause:
The Office Web Apps rely on the SharePoint Shared Services Infrastructure to convert the document into a browser ready rendition.  If the front-end machines cannot find the shared services, or the shared services are not started on at least one machine, then viewing the document or presentation will fail with this error.

Another possible cause for these errors is a potential problem with the Service Account running the Web Application, the Word Viewing Service, and the PowerPoint Service. 

Resolution:

Resolution 1: Check PowerPoint Service and Word Viewing service status:
1.    Click  Start , point to All Programs , Microsoft SharePoint 2010 Products , and then SharePoint 2010 Central Administration.

2.    On the SharePoint Central Administration home page, in Application Management , click Manage service on server .  Verify PowerPoint Service and Word Viewing Service is started.

Resolution 2:   Verify if PowerPoint Service and Word Viewing Service are not listed. 
If it is listed, then proceed to another resolution in the list.  The service applications and proxies can be created by using the Central Administration or Windows Power shell. 

To create the service applications and the service application proxies by using Central Administration:

1.    Click Start , point to All Programs , Microsoft SharePoint 2010 Products , and then SharePoint 2010 Central Administration .
2.    On the SharePoint Central Administration home page, in Application Management , click Manage service applications .
3.    On the Service Applications page, click New , and then click Word Viewing Service .
4.    In the Word Viewing Service Application dialog box, in Name , type Word Viewing Service Application . In Application Pool , select Use existing application pool , and then in the list box, select SharePoint Web Services Default . In Add to default proxy list , verify Add this service application's proxy to the farm's default proxy list is selected (default), and then click OK .

Note: You can choose to create a new application pool to be used with a service application. When creating a new application pool, you can specify the security account used by the application pool to be a predefined Network Service account, or you can specify a managed account. The account must have read\write privileges for the SPContent database and SPConfig database.

5.    On the Service Applications page, click New , and then click PowerPoint Service Application .
6.    In the PowerPoint Service Application dialog box, in Name , type PowerPoint Service Application . In Application Pool , select Use existing application pool , and then in the listbox, select SharePoint Web Services Default . In Add to default proxy list , verify Add this service application's proxy to the farm's default proxy list is selected (default), and then click OK . 

Note: You can choose to create a new application pool to be used with a service application. When creating a new application pool, you can specify the security account used by the application pool to be a predefined Network Service account, or you can specify a managed account. The account must have read\write privileges for the SPContent database and SPConfig database.

Resolution 3: Check Service Account Permissions
The Service Applications get and retrieve content and settings from the SharePoint Content Databases and the Configuration Database.  In order for them to process documents they must have appropriate permissions on both databases. 

For more information as to the recommended permissions, please see the Account permissions and security settings (SharePoint Server 2010) TechNet article found here:
http://technet.microsoft.com/en-us/library/cc678863.aspx

Resolution 4: Check the Farm Account
In a Farm Setup, we suggest that the Farm Account be running under a different account for the Web Application, PowerPoint and Word Viewing Application Pools.  To check these through the Central Administration:

1.    Click Start , point to All Programs , Microsoft SharePoint 2010 Products , and then SharePoint 2010 Central Administration .
2.    On the SharePoint Central Administration home page, in Security , click Configure service accounts .
3.    Verify they are running under a different account.  If they are the same as the Farm Account change them to a different Service Account or create a new service account in your domain to run these services.  
4.    To create a different or new service account, the following link provides the detail steps: http://technet.microsoft.com/en-us/library/dd548356(WS.10).aspx

Note:  It is not a requirement to run the Farm account and Service accounts under different managed accounts.  This resolution is provided as a possible troubleshooting technique.

If you have any queries/questions regarding the above mentioned information then please let me know.
I would be more than happy to help you as well as resolves your queries, Thank you.

16 November, 2012

SharePoint 2013 Backups and Restores


The SharePoint 2013 backup architecture and recovery processes include farm backup and recovery, granular backup and recovery, and recovery from an unattached content database. You can complete backup and recovery operations by using the SharePoint Central Administration website or Windows PowerShell cmdlets. Note that some built-in backup and recovery tools may not meet all the requirements of your organization.

Million thanks to Microsoft for publishing such wonderful articles and make it publicly available to all of us.

The following articles on TechNet and related resources provide information about backup solutions for SharePoint 2013.The IT professionals who are responsible for backup and recovery solutions are expected to have an understanding of the technical backup details.
A backup is a copy of data that is used to restore and recover that data after a system failure. While backups allow you to restore data after a failure they are also useful to keep for routine purposes. These purposes include copying a database from one server to another, setting up database mirroring, and archiving to comply with regulatory requirements.












14 November, 2012

Error Code: 3241607174


Strange error, hmm !!

When you enable a scheduled data refresh on the workbook, you receive the following error message from the SQL Server Analysis Services instance: 

Error Code: 3241607174
A connection corresponding to the embedded PowerPivot data was not found in the Excel workbook, file File Name .

If you wanna resolve this issue then please convey MILLION THANKS to Microsoft as they have already published an article on this:


12 November, 2012

How to enable the audit log in SharePoint 2013

To enable the audit log by using Central Administration

·         On the Central Administration home page,
·         In the Application Management section,
·         Click Manage service applications.
·         Select the Secure Store service application.
·         On the ribbon, click Properties.
·         From the Enable Audit section,
·         Click to select the Audit log enabled box.
·         To change the number of days that entries will be purged from the audit log file, specify a number in days in the Days until Purge field.
·         The default value is 30 days.
·         Click OK.

Configure audit settings for a site collection

Please use the following link in which Microsoft has given a very detailed description that references each and every minor point regarding audit settings:

It consists of:
·         Auditing event information
·         Trimming the audit logs (new enhancements in SP2010 and SP2013 as compare to earlier versions)
·         Configure audit log trimming
·         Configure events to audit


View audit log reports
Following link will help you to understand the following points:
·         Events available for audit log reports
·         Available audit log reports
·         View audit log reports


Please let me know in case of any queries/questions so that we can discuss and sort it out quickly.
Thank you