07 October, 2011

how to create a discussion board in sharepoint 2010

Hello Everybody-Hope all are doing well..
This time-I am going to provide some basic details regarding discussion boardsso that it will help the beginners to explore as well as learn the discussion board details. In case of any queries/questions regarding the mentioned information then please let me know. I would be more than happy to help you as well as resolves your issues, thank you
How  to create a new discussion board
1)      Open SharePoint Foundation 2010
2)      Select Site Actions
3)      More Options
4)      Select Discussion Board
5)      Enter a Name for the discussion board and choose More Options button. 
6)      Enter a Description for the discussion board
7)      Select Yes to display the discussion board on the Quick Launch
8)      Click Create
9)      This creates the discussion board with some default columns

How to view default columns:
1)      Select List Tools > List > List Settings from the toolbar. Discussion Board Settings page is displayed
2)      Scroll down to view the columns (please refer the following screenshot)
How to Create Columns in discussion board:
 Click Create Column link:
Create the following additional columns (1) Priority  (2) Status and (3) Section Impacted
Create a Priority column as follows to track items based on priority. For example, you would like to track High priority items separately and ensure that adequate resources are available for a quicker resolution. There should be guidelines available on how the items are to be classified as Low, Medium, or High and it should be communicated to the reviewers. 

How to create a Priority column:

  • Enter Priority in the Column name field
  • Select Choice for 'The type of information in this column is' field
  • Optionally enter a Description. The description will be displayed when a feedback item is created
  • Select No for 'Require that this column contains information' and Enforce unique values fields
  • Enter Medium, Low, High (each choice on a separate line) in the 'Type each choice on a separate line' text box
  • Select Drop-Down Menu as the value for 'Display choices using'
  • Select No for Allow 'Fill-in' choices. This prevents the user from creating additional Priority values
  • Select 'Choice' radio button for Default value field and enter Medium as the value. For all new items created, the Priority will default to Medium
  • Accept the default values (selected) for Add to all content types and Add to default view
  • Click OK to create the Priority column
How to create status column

·         Enter Status in the Column name field
  • Select Choice for 'The type of information in this column is' field
  • Optionally enter a Description. The description will be displayed when a feedback item is created
  • Select No for 'Require that this column contains information' and Enforce unique values fields
  • Enter Open, Closed (each choice on a separate line) in the 'Type each choice on a separate line' text box
  • Select Drop-Down Menu as the value for 'Display choices using'
  • Select No for Allow 'Fill-in' choices. This prevents the user from creating additional Priority values
  • Select 'Choice' radio button for Default value field and enter Open as the value. For all new items created, the Status will default to Open
  • Accept the default values (selected) for Add to all content types and Add to default view
  • Click OK to create the Status column
How to Create Section Impacted Column
·         Enter Section Impacted in the Column name field
·         Select Choice for 'The type of information in this column is' field
·         Optionally enter a Description. The description will be displayed when a feedback item is created
·         Select Yes for 'Require that this column contains information' and 'No' for Enforce unique values field
·         Enter Configuration, Details (each choice on a separate line) in the 'Type each choice on a separate line' text box
·         Select Drop-Down Menu as the value for 'Display choices using'
·         Select No for Allow 'Fill-in' choices. This prevents the user from creating additional Priority values
·         Select 'Choice' radio button for Default value field and leave the default value blank. For all new items created, the Section Impacted field has to be selected
·         Accept the default values (selected) for Add to all content types and Add to default view
·         Click OK to create the Section Impacted
How to create a discussion Item
1)       Click Add new discussion
2)       Enter the Subject of the discussion or feedback. Be descriptive and keep it short
3)       Enter the details of the discussion or feedback raised in the Body field
4)       Change the default Priority value if required
5)       Accept the default Status value
6)       Select the appropriate value for Section Impacted
7)       Click Save to add the discussion item
8)       The discussion item is created.
How to Reply to Feedback Item
·         Click the Subject of the discussion item
·         Click Reply
·         Enter reply in the Body field as shown in the screen print
·         Click Save

Hide Columns in Message Content Type
·         Select List Tools > List > List Settings
·         Select Message Content Type
·         Select Priority Column
·         Select Hidden under Column Settings and click OK
·         Similarly, change the value to Hidden for Status and Section Impacted columns

How to Create an Alert
·         Select List Tools > List > Alert Me > Set alert on this list
·         Enter a descriptive Alert Title. If you have setup alerts on several lists, a descriptive title will help you to categorize. For example, having the list or the view name as the Alert Title
·         Enter the Users to be notified
·         Select the Delivery Method
·         Specify the type of changes that you want to be alerted to
·         Determine whether to filter alerts based on specific criteria or be notified of all changes. Filter based on a specific view is useful if you are interested in being alerted only of the categories you are responsible for
·         Determine whether to have the notification sent immediately or a daily summary, or weekly summary
·         Click OK to complete

Export to Excel
·         Open the Team Discussion Board
·         Select Export to Excel
·         Click Open in the File Download window that appears
·         Click Enable in the Microsoft Excel Security Notice dialog to enable data connections
·         This opens Microsoft Excel spreadsheet with the Discussion Board columns.

Data Connections
·         Select Data > Connections to view the Workbook Connections
·         Select Data > Refresh All to sync data between the Workbook and Discussion Board

Refferences:

01 October, 2011

Vista - Upload multiple documents - zip files not visible

Today I worked on one issue and would like to share the design behavior of it so that we can keep a note and resolves the forthcoming issues in flexible manner.

Problem Description:
When we try to do "Upload Multiple Documents", we are able to locate our files on our laptops except for zip files.
For some odd reason, we can't see our zip files when choosing "Upload Multiple Documents". When we choose the Upload Document option, we are able to locate our zip files.

Machine Configuration:
·         Windows Vista with latest service packs
·         Office 2007
·         Internet explorer 7.0

Resolution:
Did some research and found the Microsoft KB which suggest that it is a design behavior with windows vista machines and needs registry modifications to fix it completely.


Fix Suggested:
To fix this problem you need to delete the following registry keys. 
HKEY_CLASSES_ROOT\CLSID\{E88DCCE0-B7B3-11D1-A9F0-00AA0060FA31} 
HKEY_CLASSES_ROOT\CLSID\{0CD7A5C0-9F37-11CE-AE65-08002B2E1262}

Workarounds available:
1)      Document Library explorer view
2)     Document library single file upload
3)     Create a network share

Note: In above scenarios, we need to transfer the ticket to desktop support team if we don’t have rights to do any kind of registry changes on user’s machine.

If you have any queries/questions regarding the mentioned information then please let me know. I would be more than HAPPY 2 HELP U as well as RESOLVES your issues…

cannot open flash files in SharePoint / cannot play .swf files in SharePoint


Flash files (.SWF extensions) are by default unblocked in SharePoint so it means we can store the flash files inside our document libraries. One of my users has opened a case with our team and asked for guidance as How to play the flash files in SharePoint.

One thing I need to clarify here is Flash is an independent application which is part of your desktop and we are using SharePoint to store them as a repository purpose. So when you play them then one of the most important thing to understand what exactly happens in the background.

1) Desktop installed flash application helps the stored file to start running.
2) Play the flash file in HTML mode (i.e. by means of explorer)

If your flash file is not running then the most probably the problem is with internet explorer or client/application is missing from the desktop.

One of the quickest workaround is- try to play that flash file by means of Mozilla or Google chrome. If it’s running then HTML mode is working fine in those browsers. If it’s not working in your Internet explorer then some add-on is missing.

Multiple ways that you can try-Please refer the following details:

If you don't have the full version of Flash installed on your PC, then you also don't have a standalone Flash player installed on your system and you aren't able to start SWF files through a double click on it.

The Flash Plugin in your Browser is not the same as the standalone Flash player, instead the Flash Plugin only allows you to play SWF files in your Browser.

But you're able to drag and drop SWF files onto your Browser to play them within the Browser, if you don't want to install the separate available standalone Flash Player.

1. Right Click on swf file. Select Open With. Chose IE7 and FF3, worked in both cases.
2. or, double click any swf file and then elect to "browse" and associate browser (FF or IE) with swf files so they open in browser.

There are several free standalone Flash players available. Just Google for them. The one I'm using currently is the Swiff player.

One more thing that i would like to notify-if you are using SharePoint Server 2010 then please refer the following details:
1.      Got to Central Admin
2.    Web Application Management
3.    Select your web app
4.    Select General Settings on the ribbon
5.     Set the Browser File Handling to Permissive

That's it-If you have any queries/questions regarding the mentioned information then please let me know.
I would be more than HAPPY 2 HELP U as well as RESOLVES UR issues, Thank you...

12 September, 2011

How to export a site, list, or document library-SharePoint Server 2010

Mandatory Requirements:
You must create a folder on the local computer or the network in which to store the export file.
How to export a site, list, or document library by using Central Administration:
  1. Verify that the user account that is performing this procedure is a member of the Farm Administrators group.
  2. In Central Administration, on the Home page, click Backup and Restore.
  3. On the Backup and Restore page, in the Granular Backup section, click Export a site or list.
  4. On the Site or List Export page, in the Site Collection section, select the site collection from the Site Collection list, and then select the site from the Site list.
  5. If you are exporting a site, skip this step, Select the list or document library from the List.
  6. In the File Location section, in the Filename box, type the UNC path of the shared folder and the file to which you want to export the list or document library. The file name must use the .cmp extension.
  7. If the file already exists and you want to use this file, select the Overwrite existing files check box. Otherwise, specify a different file name.
  8. If you want to export all the security and permissions settings with the list or library, in the Export Full Security section, select the Export full security check box.
  9. If you want to specify which version of the list or library to export, select one of the following versions from the Export versions list:
1)       All Versions
2)      Last Major
3)      Current Version
4)      Last Major and Last Minor
  1. When you have specified the settings that you want, click Start Export.
If you have any queries/questions regarding the mentioned information then please let me know…

Server error: http://go.microsoft.com/fwlink?LinkID=96177

Problem Description:
Where to check and how to cross checked:
·         Open the Event viewer application and check 4 these event ID’s:
5617, 100, 104
Error Message: Server error: http://go.microsoft.com/fwlink?LinkID=96177
Probable causes:
1.       Windows Update
2.      Service pack installation
Resolution:
1.       Create a new web application with a new test database
2.      Central Administration
3.      Application Management
4.      Content Databases
5.      Change the web application to the new one that you had created
6.      Detached the database
7.      Change the web application to the problem site and detached the database for that web application as well
8.     Command prompt and run the below mentioned command
Stsadm -o addcontentdb -url <type new url address> -databasename <type database name>

 If you have any queries/questions regarding the mentioned information then please let me now...
I would be more than HAPPY to HELP U as well as RESOLVES UR Issues :-) :-)

No results matching your search were found

Problem Description:
When you try to perform search on your SharePoint site on your SharePoint server then you are getting the below mentioned error message:

No results matching your search were found.
Check your spelling. Are the words in your query spelled correctly?
Try using synonyms. Maybe what you’re looking for uses slightly different words.
Make your search more general. Try more general terms in place of specific ones.
Try your search in a different scope. Different scopes can have different results.


What to check first: Make sure the Windows SharePoint help search is working

Resolution:
Create a registry in the following location:
1.      HKLM\System\CurrentControlSet\Control\Lsa
2.      Create a new DWORD key named “DisableLoopbackCheck” and modified the value  to 1
3.      Performed Full Crawl by using the stsadm command:
stsadm -o spsearch -action fullcrawlstart

That’s it-Your issue will be resolved and Search will start working without any problems.

If you have any queries/questions regarding the mentioned information then please let me know...
I would be more than HAPPY to HELP U as well as RESOLVES UR issues :-) :-)

Event ID 8214: “Object reference not set to an instance of an object”

Problem Description:
When you perform Check-Out documents from the Document Library where document check-out is required from the SharePoint site in your SharePoint farm, you are getting following error message
“Object reference not set to an instance of an object”
Impact: You are not able to open and edit any office documents
When you will not face the issue: You are not facing the issue on the document library where check-out is not required to edit the documents
Why the problem occurred: Issue started to occur when you installed WSS 3.0 SP2 on you SharePoint server
How you will cross checked: Event Viewer ApplicationàEvent ID 8214
Event Type:        Error
Event Source:    Windows SharePoint Services 3
Event Category:                Topology
Event ID:              8214
Date:                     5/12/2009
Time:                     3:21:14 PM
User:                     N/A
Description:
The description for Event ID ( 8214 ) in Source ( Windows SharePoint Services 3 ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: A request was made for a URL, http://novashare, which has not been configured in Alternate Access Mappings.  Some links may point to the Alternate Access URL for the default zone, http://spadmin.  Review the Alternate Access mappings for this Web application at http://spadmin/_admin/AlternateUrlCollections.aspx and consider adding http://spadmin as a Public Alternate Access URL if it will be used frequently.  Help on this error: http://go.microsoft.com/fwlink/?LinkId=114854.
Resolution:
1.       Central Administration site
2.      Operations
3.      Alternate Access Mappings
4.      Show AllàChange Alternate Access Mapping Collection
5.      Select the Web Application which belongs to the problem site
6.      There is a URL that is reflecting in “Default” zone
7.      Now specify the URL which is giving you problem in the “Intranet” zone
8.     IISRESET
That’s it- Your issue will be resolved and you should be able to check-out and edit the office documents


08 September, 2011

Downloadable content for SharePoint Foundation 2010

Microsoft SharePoint Foundation 2010 architecture and concepts.
ALL CREDIT GOES TO MICROSOFT TEAM 4 MAKING THIS VALUABLE DATA AND PUBLICLY AVAILABLE ALL OVER THE WORLD

Best practices SharePoint Server 2010