01 November, 2012

SharePoint Pro Resources: eBooks

Download the latest SharePoint administration and development resources from SharePoint Pro. Keep up to date with the latest technology and IT trends, tips, and research.

eBooks

Hyper-V Data Protection Trends By AppAssure Software

The Essential Guide to Lossless iSCSI By Brocade, Hitachi Data Systems

Podcasts


Secure Copy By Dell|Scriptlogic
Security Explorer - 12 Jul 2012 By Dell|Scriptlogic


On-Demand Web Seminars

An Overview of the Vital Role of Fax By Instant InfoSystems


Utility Resources

 

Voting buttons are not visible in Outlook when you open a SharePoint alert notification that is forwarded


Problem Description:
In Microsoft Outlook, when you double-click to open a Microsoft SharePoint alert notification that is forwarded to you, voting buttons that the sender added may not be visible.

Error Message:
Vote by clicking in the Respond group above. However, no Respond group is available.

Probable Cause:
The Share Ribbon tab on the message that is opened contains custom SharePoint buttons, such as the Connect to this Document Library button and the Preview this Document Library button. The original Message tab, where the Vote drop-down button typically appears, is not available.

Resolution:
Use the Reading Pane to access the voting options. To enable the Reading Pane, follow these steps:

·         In the main Outlook window, click the View Ribbon tab. 
·         Click the Reading Pane button, and then click either Right or Bottom . 
·         Click one time on the message that was forwarded to display the message in the Reading Pane. In the message header area of the Reading Pane, click Click here to vote to make a voting selection.

How exactly I reproduced the issue?

1.    Open a SharePoint document library in Windows Internet Explorer on a SharePoint site that is configured to send email messages. 
2.    On the SharePoint ribbon, click Library Tools, click Documents, click Alert Me, and then click Manage My Alerts. 
3.    Click Add Alert. 
4.    Select the document library that you opened in step 1, and then click Next . 
5.    Confirm that Send Alerts To is set to an email account that can be checked by using Outlook 2010, Delivery Method is set to email , Change Type is set to All Changes , Send Alerts for These Changes is set to Anything changes , and When to Send Alerts is set to Send notification immediately . Then, click OK . 
6.    Browse to the document library that you opened in step 1. 
7.    Make a change to the document library, such as deleting a document or uploading a document. 
8.    In Outlook 2010, select the message that explains the change that you made in step 7.
9.    Click Forward. 
10. In the forward message window, click Options, click Use Voting Buttons , and then click Approve; Reject . 
11. Specify a recipient, and then click Send. 
12. On the recipient's computer where Outlook is installed, double-click the message that you sent in step 11 to open the message in message view.

If you have any queries/questions regarding the above mentioned information then please let me know.
I would be more than happy to help you as well as resolves your issues, Thank you.

31 October, 2012

Personal views in site migration using Import-Export commads

Personal Views does not get imported/migrated when we do a site import-export on the sub-site or site collection level.

This is a known issue with the product, however, Microsoft doesn’t have any technical reference for this other then the discussion on the Technical Forum.

Other problem occurred with import exports are:

•           All personalization’s are completely lost (personal views, workflows and alerts) 
•           Various customizations are also lost
•           Sites based off old site templates are not handled
•           During import, some files are dropped off due to the blocked items list.
•           There are some versioning and security issues as well.

We have tested the above specification in our environment and results are same.

Error '0x80040e09' occurred during full-text index population for table or indexed view '[DB Name].[dbo].[CurrentPostCombined]': SQL Full Text Search Continued.

In continuation of the Full text search articles discussed before Article 1 and Article 2. Today we finally cracked the resolution of the error message below with the help on MS.
Crawl Log
"2012-08-31 19:01:39.11 spid19s Error '0x80040e09' occurred during full-text index population for table or indexed view '[DB Name].[dbo].[CurrentPostCombined]' (table or indexed view ID '207548023', database ID '15'), full-text key value 0x0000000000ADD0C4. Attempt will be made to reindex it.
2012-08-31 19:01:39.11 spid19s The component 'sqlfth90.dll' reported error while indexing. Component path 'C:\Program Files\Microsoft SQL Server\90\COM\sqlfth90.dll'."
Error log
2012-08-31 19:05:38.15 spid137     Error: 7683, Severity: 16, State: 1.
2012-08-31 19:05:38.15 spid137     Errors were encountered during full-text index population for table or indexed view '[DB Name].[dbo].[ArchivePost]', database 'ngservices' (table or indexed view ID '1813581499', database ID '15'). Please see full-text crawl logs for details.
Error ‘'0x80040e09' indicates Permission was denied for the account running SQL Server Full-Text Search, hence account will need elevated credentials.
RESOLUTION:
Use a low privileged Domain account to run SQL Server Full-Text Search service and restart the service. Please have a look at the following article for more information http://msdn.microsoft.com/en-us/library/ms143504(v=sql.90).aspx
In our environment the SQL Full text search service was running under Local system account. Changing it to run with the SQL Account resolved the issue.
We monitored the file size and it stopped growing.
Hope this helps you to resolve the issue in your environments.

There was an error opening this document. The selected file cannot be found


Problem Description:
When you print the multiple PDF files in Microsoft Office Outlook 2007, you receive the following error message from Adobe Reader:

"There was an error opening this document. The selected file cannot be found."

Resolution:
To resolve this issue, apply the following update: http://support.microsoft.com/kb/2276479  

After you install the hotfix package, follow these steps to enable the hotfix:

Click Start , click Run , type regedit in the O pen box, and then click OK.

Locate and then select the following registry subkey:

HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Options

On the Edit menu, point to New , click  Key , type Attachments , and then press ENTER. 

Locate and then select the following registry subkey:

HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Options\Attachments 

On the Edit menu, point to New, click DWORD(32-bit) Value , type FileTrackIdle , and then press ENTER. 

Right-click FileTrackIdle , and then click  Modify.

In the Value data box, type 5000, and then click OK.

Note If the issue persists, increase the value data by 1000 until you can successfully print all the PDF files. 

Exit Registry Editor.

Note: Before making any changes in the registry, I would request you to take the backup first and then make the changes.

How to back up and restore the registry in Windows XP
http://support.microsoft.com/kb/322756

Please let me know in case of any queries/questions regarding the above mentioned information. I would be more than happy to help you as well as resolves your issues, Thank you.