Cannot open file: it does not appear to be a valid archive. If you downloaded this file, try downloading the file again.
CAUSE
This problem may occur if HTTP compression is turned on in the Web Sites properties of Microsoft Internet Information Services (IIS) on the SharePoint virtual server. When you download a .ZIP file, IIS encodes the file as GZIP. However, the browser client passes the file directly to the unZIP program, without GZIP decoding the file. To determine if HTTP compression is turned on, follow these steps:
1. Click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
2. Expand the server (local computer) tree, where server (local computer) is the name of your IIS server.
3. Right-click Web Sites, and then click Properties.
4. Click the Service tab to view the HTTP compression properties.
Resolution:
change the MIME type for the .ZIP file from application/x-zip-compressed to application/octet-stream . To change the MIME type, follow these steps:
1. Click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
2. Right-click the server (local computer) tree, where server (local computer) is the name of your IIS server, and then click Properties.
3. Click MIME Types.
4. Scroll down the registered MIME type list to find the .zip entry.
5. Click the .zip application/x-zip-compressed entry, and then click Edit.
6. Change the MIME type value to application/octet-stream .
7. Stop and then restart the IIS Admin Service to apply the change to the MIME type.