06 April, 2009

Office Server Search Service cannot be started because it does not exist.(Object reference not set to an instance of an object)


Office Server Search Service cannot be started because it does not exist.
Few Days before, I tried to setup my lab and after the installation, i tried to start the search service but mystery is here, when i checked CA-operations-services on server-OSEARCH is not there. I have the right key , the right CD and the latest fixes.I installed it and it is simply not there.
As you can probably guess, there’s nothing wrong with your PC or Cd or key, you simply did not installed the server in the correct way to receive all the services.

Please check:-
regedit and check the value under the following key :
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\WSS\
ServerRole
Possible options:
WFE
APPLICATION
SINGLESERVER

Each option means :
WFE - Windows SharePoint Services Web Application (no search , no excel, no ssp, just web server)
APPLICATION –Everything (and you can add the server to a farm)
SINGLESERVER –Everything (but you cannot add the server to a farm , and most probably you have MSDE or SQL Server Express on the box too)

To change the installation mode for the server (even if you managed to create webapplications and set-up your sharepoint config db), here’s the procedure:
-Detach the server from the farm
-Uninstall Sharepoint
-Reboot the server
-Re-install Sharepoint in Advanced mode and select your desired server role.
-Run the configuration wizard and re-attach the server to the original farm (config_db)
You should get the applications back and everything else in place, as they were but with new services in the farm.






No comments:

Post a Comment

Your feedback is always appreciated. I will try to reply to your queries as soon as possible- Amol Ghuge